GLSL Shaders Mod 1.7.10, 1.7.2, 1.6.4, 1.5.2

GLSL Shaders Mod 1.7.10, 1.7.2, 1.6.4, 1.5.2

What is GLSL Shaders Mod?

GLSL Shaders is a modification for Minecraft 1.7.10/1.7.2/1.6.4 that brings OpenGL based Shader graphics in your Minecraft world and make it look fabulous. It enables a lot of effects such as improved shadows, better lighting and connected textures by utilizing the power of your PCIe Graphic card. GLSL shaders is often used with Sonic Ether’s Unbelievable Shaders to maximize the visual effects of shaders in Minecraft.

GLSL Shaders Features:

  • Supports HD resource/texture packs. Support multiple composite programs (compostire1, composite2, composite3)
  • Shader packs such SEUS, MAC Shaders, Bump Shadow waving are supported
  • Minecraft Forge and OptiFine Compatibility
  • Easy installation without any hassle

How to install GLSL Shaders Mod:

Install for Minecraft 1.7.10, 1.7.2, 1.6.4, 1.6.2

Before Install

  • Install Forge or FML
    • Download Minecraft Forge or FML installer
    • Open Minecraft Launcher.
    • Select a profile (lower left corner of launcher window).
    • Edit Profile. Select Minecraft version that is compatible with Forge and ShadersMod (1.7.10, 1.7.2, 1.6.4) and save.
    • Click play. Wait for Minecraft to load.
    • After the game start successfully, close Minecraft.  Close launcher if it is still open.
    • Install Minecraft Forge or FML with the downloaded installer.
    • Open Minecraft Launcher.

Select Forge or FML in profile box at lower left corner of launcher window. Or select other profile and click Edit Profile and select Forge or FML version and save.

    • Click Play.
    • You should see “Mods” button in title screen below “Multiplayer” button.
  • Check whether everything is alright and close Minecraft.

Install

  • Copy ShadersModCore-….jar to %appdata%\.minecraft\mods folder. Make sure its file extension is “.jar”, not “.zip”.
  • If you want to install other FML mods or Forge mods, copy them to the same mods folder.

Run

  • Use Mojang’s Minecraft Launcher to run Minecraft with Forge profile. (Don’t worry if ShadersMod is not shown in mod list screen)
  • Open Option menu, Shaders… button.  Click open shaderpacks folder.
  • Put some shaderpacks in the folder.
  • In Shaders screen click shaderpack name.

Install for Minecraft 1.7.5:

  • This requires Java 7.
  • Before running this installer, run Minecraft 1.7.5 at least once and close it.
  • Close Minecraft Launcher before you run this installer.
  • The installer is executable jar file. Double-click to run.
  •   If your computer doesn’t associate .jar with Java, you may have to run java from command line or batch file.

    java -jar ShadersMod-v2.3.15mc1.7.5-installer.jar

This version is compatible with OptiFine_1.7.5_HD_U_D1. 
Run OptiFine installer before ShadersMod installer. 

Install for Minecraft 1.7.4:

  • This requires Java 7.
  • Before running this installer, run Minecraft 1.7.4 at least once and close it.
  • Close Minecraft Launcher before you run this installer.
  • The installer is executable jar file. Double-click to run.
  •   If your computer doesn’t associate .jar with Java, you may have to run java from command line or batch file.

    java -jar ShadersMod-v2.3.13mc1.7.4-installer.jar

This version is compatible with OptiFine_1.7.4_HD_U_D1. 
Run OptiFine installer before ShadersMod installer. 

Installation for Minecraft 1.5.2/1.4.7/1.4.6 (GLSL Shaders Mod v1.4x)

You need correct version of minecraft and OptiFine. Wrong version does not work.

Example:

ShadersMod-mc1.4.6-ofuD5-1.43 for Minecraft 1.4.6-1.4.7

    • is to be used with OptiFine 1.4.6_HD_U_D5.
    • will not work with OptiFine 1.4.6_HD_D5 (standard edition not ultra).
    • will not work with OptiFine 1.4.6_HD_U_C3 (wrong OptiFine version).
    • will not work with OptiFine 1.4.5_HD_U_D5 (wrong Minecraft version).

MCPatcher HD fix is not compatible. Modloader is not compatible.

 Forge is compatible.  See compatible Forge version number in OptiFine. Forge includes FML which provides modloader functionality.

Installation for use with Magic Launcher

  • 1. Open Magic Launcher.
  • 2. Click Setup button.
  • 3. Select or create configuration you want to use.
  • 4. If you use Forge, add Forge universal zip.
  • 5. Add OptiFine zip (below Forge universal if used together).
  • 6. Add ShadersMod zip below OptiFine.
  • 7. Add shaders zip file (which has *.fsh *.vsh in shaders folder inside zip)
  • 8. Go back to Minecraft Shaders GUI.  Click shaderpack name from the list.

Manual installation in minecraft.jar

  • 1. Make a backup of original minecraft.jar. (You may want it later.)
  • 2. Open minecraft.jar in WinRAR or 7-Zip or similar program.
  • 3. Delete META-INF in minecraft.jar.
  • 4. If you use Forge, copy files from Forge universal zip into minecraft.jar
  • 5. Copy files from OptiFine zip into minecraft.jar.
  • 6. Copy files from ShadersMod zip into minecraft.jar
  • 7. Copy *.fsh *.vsh files into minecraft.jar/shaders  (or leave it empty and copy *.fsh *.vsh into .minecraft/shaders folder instead)
  • 8. Go back to Minecraft Shaders GUI.  Click shaderpack name from the list.
Shaderpacks
  • bump-shadow-waving 0.9.8
    • Fixed compatibility with NVIDIA 334.89.
  • bump-shadow-waving 0.9.7
    • Demonstrate the use of multiple depth buffers, multiple shadow buffers and shadow color buffer.
    • Underwater shading is still incomplete — it is too bright now.
    • Compatible with NVIDIA, AMD, Intel HD Graphics.
  • bump-shadow-waving v0.9.6
    • Demonstrate the use of multiple depth buffers and shadow depth buffers and shadow color buffer.
    • Water and Portal have colored shadow.
    • Opaque objects above water cast shadows on both water surface and underwater.
    • Underwater shading is still incomplete.
    • Bug: incompatible with AMD
  • bump-shadow-waving v0.9.3
    • Fixed waving grass and flowers problem in 1.6.x.
    • Do not move bottom vertices of water.
    • Rain is still not good.
    • Require ShadersMod preview 3 or v2.0.1 beta 1 for Minecraft 1.6.2.
  • Sonic Ether’s Unbelievable Shaders
  • Sildur’s Shaders
How to prepare shaderpack zip file:
  • Make a folder named shaders
  • Copy *.vsh *.fsh files in the folder
  • Zip the folder.
  • Make sure the zip file has shaders folder in it with *.vsh *.fsh in shaders folder.
  • Rename your zip file for easy identification.
How to prepare shaderpack folder for in-game shaders selection
  • Start Minecraft with ShadersMod installed
  • Option… Shaders… open shaderpacks folder
  • Create subfolder .minecraft/shaderpacks/packname
  • Create subfolder .minecraft/shaderpacks/packname/shaders
  • Copy your .fsh .vsh files into .minecraft/shaderpacks/packname/shaders
Here is folder structure for .minecraft/shaderpacks:
[.minecraft]└─[shaderpacks]├─[packname1]└─[shaders]├─*.vsh
└─*.fsh
├─[packname2]└─[shaders]├─*.vsh
└─*.fsh
├─{packname3.zip}└─[shaders]├─*.vsh
└─*.fsh
├─{packname4.zip}└─[shaders]├─*.vsh
└─*.fsh
└─...

Changelogs:

Show Changelogs
V2.3.18

  • Update to Minecraft 1.7.10

V2.3.15 (For MC 1.7.5):

  • Not require Forge.
  • Compatible with OptiFine_1.7.5_HD_U_D1.

V2.3.13 (For MC 1.7.4):

  • Not require Forge.
  • Compatible with OptiFine_1.7.4_HD_U_D1.

V.2.3.12 (For MC 1.7.2):

  • Requires Forge or FML.
  • Compatible with Optifine.
  • Recent changes:

. Fixed crash if used with FML without Forge (v2.3.10-2.3.11).
. Fixed mc_Entity.z and gl_MultiTexCoord3 not work in v2.3.10. . Fixed flashing shadow . Fixed held item rendering . Added program gbuffers_spidereyes . Changed mc_Entity x=blockID, y=renderType, z=metadata . Added shader settings : shadowtex0Mipmap, shadowtex1Mipmap, shadowcolor0Mipmap, . shadowcolor1Mipmap, shadowtex0Nearest, shadowtex1Nearest, shadowcolor0Nearest, shadowcolor1Nearest (to be used by SEUS GI algorithm)

Tips and Warnings:

  • Make sure you have above average graphic card and RAM on your PC. For e.g. Nvidia GeForce GTX 460 with 4GB RAM or better. Intel core i3, i5 or i7 4th generation processors are recommended.
  • Mac OS will give compatibility issues due to lack of proper OpenGL support
  • Update your ATI or Nvidia video card drivers to the latest. This is very important.
  • Magic Launcher can be used for installation.

DOWNLOAD GLSL Shaders Mod :

Shaders:

Sildur’s Shaders: http://3minecraft.com/sildurs-shaders-mod/ Chocapic13′s Shaders: http://3minecraft.com/chocapic13-shaders-mod/ Sonic Ether’s: http://3minecraft.com/sonic-ethers-unbelievable-shaders-mod/ CUDA Shaders: http://3minecraft.com/cuda-shaders-mod/ RudoPlays Shaders: http://3minecraft.com/rudoplays-shaders-mod/ Waving Plants Shaders: http://3minecraft.com/waving-plants-shaders-mod/

For 1.4.7/1.4.6 (for Minecraft 1.4.6-1.4.7 OptiFine HD Ultra D5)

ShadersMod-mc1.4.6-ofuD5-1.44.zip

For 1.5.2 (for Minecraft 1.5.2 OptiFine HD Ultra D3)

ShadersMod-mc1.5.2-ofud3-1.46.zip

For 1.6.2

ShadersModCore-1.6.2.jar

For 1.6.4

ShadersModCore-v2.2.2-mc1.6.4-f965.jar

For 1.7.2

ShadersModCore-v2.3.17-mc1.7.2.jar

For 1.7.4

ShadersMod-v2.3.13mc1.7.4-installer.jar

For 1.7.5

ShadersMod-v2.3.15mc1.7.5-installer.jar

For 1.7.10:

Forge: ShadersModCore-v2.3.18-mc1.7.10-f1179.jar

Non-Forge: ShadersMod-v2.3.19mc1.7.10-installer.jar

Credits: karyonix


  • awoedikghjjsl

    THere is no downlaod link on this page

  • imac1844

    I really love this mod… When is 1.7.9 projected for? Is there another page with it already that I don’t know about?

    • Ultra Gamerz

      its 1.7.10 not 1.7.9

      • imac1844

        It wasn’t 1.7.10 two months ago.

        • Ultra Gamerz

          oh,k

  • Okami Amaterasu

    There is no 1.7.9 download?

  • dragman200 .

    is this good for this? Video card:ATI radeon hd 4870 sapphire processor:AMD pheanom II 2.6 4X RAM:4gb

    • Ultra Gamerz

      yes, but you need lower shaders, my pc specs are: nvidia gt520 intel core i9 5.7GHZ (yes, i9 isn’t in stores yet, but i applied for testing, it has 10 cores!) 32 gb ram

  • Guest

    A DOWNLOAD BUTTON WOULD BE NICE

    • Jade Kropman

      You read my mind!

  • Todd Massey

    where are the vsh and fsh files

    • Todd Massey

      PLEASE REPLY

  • crazygamer31230

    I installed everything successfully, including the SEUS shaderpack, but everything is really blurry, and I can’t figure out why. Can someone help me?

  • Louis Mison

    im on a mac and when i try and go into minecraft with the forge profile the mojang thing dosnt come up?

Download Minecraft Mods, Texture Packs, Resource Packs, Tools and Maps 1.8, 1.7.10, 1.7.2, 1.6.4